I just wanted to mention that I made the commit that renamed the source
and header files in drivers/lio-core/Makefile:target_core_mod-objs to
use the target_core_* prefix.
This should make things alot easier for folks who are reading the code
to see and understand the split between target_core_mod and
iscsi_target_mod, as well as the split between target_core_mod and Linux
storage subsystem plugins..
There are still some functions/defines that use the ISCSI_* and/or
iscsi_* prefix in target_core_* code, as well as iscsi_target_core.h
needs to be seperated out into target_core_mod.h. I will be spending
time on finishing up these parts soon, so if anyone is interested in
learning how things work (I will happily accept patches too :-) please
have a look at: